製品 > ArcGIS Engine > 動作環境 > ArcGIS Engine 10.5 動作環境

ArcGIS Engine

ArcGIS Engine 10.5 動作環境

サポートするオペレーティング システム

サポートするオペレーティング システム テスト済みの最新アップデートまたはサービス パック
Windows 10 Pro、Enterprise(64-bit(EM64T)) Anniversary Update
Windows 8.1 Basic、Pro、Enterprise(32-bit、64-bit(EM64T)) Update:2016 年 9 月
Windows 7 Ultimate、Professional、Enterprise(32-bit、64-bit(EM64T)) SP1
Windows Server 2016 Standard、Datacenter(64-bit ([EM64T])
Windows Server 2012 R2 Standard、Datacenter(64-bit(EM64T)) Update:2016 年 9 月
Windows Server 2012 Standard、Datacenter(64-bit(EM64T)) Update:2016 年 9 月
Windows Server 2008 R2 Standard、Enterprise、Datacenter(64-bit(EM64T)) SP1
Windows Server 2008 Standard、Enterprise、Datacenter(32-bit、64-bit(EM64T)) SP2

ハードウェア要件

CPU の速度 2.2 GHz 以上
ハイパースレッディング(HHT)、またはマルチコア推奨
プラットフォーム x86 または x64 (SSE2 対応)
メモリ/RAM 2 GB 以上
画面のプロパティ 24 ビット カラー
画面の解像度 通常サイズ(96 dpi)で 1024 x 768 ピクセル以上(推奨)
ディスク容量(ArcGIS Engine のみ)

1.6 GB(必須)

※ArcGIS Engine は使用時にキャッシュ ファイルを作成するため、追加のディスク容量が必要となります。

ビデオ/グラフィック アダプター

ビデオ メモリ: 64 MB(必須)、256 MB(推奨)。NVIDIA、ATI、Intel チップセットをサポートします。

24 ビット対応のグラフィック アクセラレーター

OpenGL 2.0 以上のランタイムが必要、Shader Model 3.0 以上を推奨

必ず最新のドライバーをご使用ください

ソフトウェア要件

Python 要件
(ジオプロセシング)

ArcGIS Engine のジオプロセシング ツールを実行するためには、Python 2.7.12 と Numerical Python 1.9.3 がインストールされている必要があります。 ArcGIS Engine をインストールするコンピューターに Python 2.7.12 と Numerical Python (NumPy) 1.9.3 が存在しない場合、ArcGIS Engine のインストーラーにより、Python 2.7.12 と Numerical Python 1.9.3 がインストールされます。またカスタム インストールを選択して Python をインストールしないようにすることもできます。さらに、ArcGIS Engine のインストール時に Python のセットアップが実行される場合、インストール場所を選択することができますが、Python のインストール場所にはパスに空白を含んではいけません。

Microsoft .NET Framework 要件 Microsoft .NET Framework を使用して開発したソリューションのために Microsoft .NET Framework 4.5 以上 がインストールされている必要があります。
ブラウザ要件 ArcGIS Engine は、Microsoft Internet Explorer 9.0 以上が必要です。Microsoft Internet Explorer 9.0 以上がインストールされていない場合は、ArcGIS Engine をインストールする前に、Internet Explorer 9.0 以上をインストールする必要があります。Internet Explorer 9、10、11 に対応しています。

ライセンス マネージャー要件

サポートするオペレーティング システム テスト済みの最新アップデートまたはサービス パック
Windows 10 Pro、Enterprise(64-bit (EM64T)) Anniversary Update
Windows 8.1 Basic、Pro、Enterprise(32-bit、64-bit(EM64T)) Update: 2016 年 9 月
Windows 7 Ultimate、Professional、Enterprise(32-bit、64-bit(EM64T)) SP1
Windows Server 2016 Standard、Datacenter(64-bit(EM64T))
Windows Server 2012 R2 Standard、Datacenter(32-bit、64-bit(EM64T)) Update: 2016 年 9 月
Windows Server 2012 Standard、Datacenter(32-bit、64-bit(EM64T)) Update: 2016 年 9 月
Windows Server 2008 R2 Standard、Enterprise、Datacenter(32-bit、64-bit(EM64T)) SP1
Windows Server 2008 Standard、Enterprise、Datacenter(32-bit、64-bit(EM64T)) SP2
Red Hat Enterprise Linux Server 6(32-bit、64-bit)* Update 1
Red Hat Enterprise Linux Server 5(32-bit、64-bit)* Update 7 以上 とlibX11 パッチ

* [License Server Administrator] と [Software Authorization Wizard] を起動するには、OpenGL が必要です。

ライセンス マネージャーのハードウェア要件は、上記の ArcGIS Engine 10.5 ハードウェア要件と同じです。

開発ソリューション(SDK)要件

ArcObjects SDK サポートおよび推奨する統合開発環境 SDK 要件 ディスク容量
ArcObjects SDK for the Microsoft .NET Framework

Microsoft Visual Studio 2013 (C#、VB.NET) Community、Professional、Premium、Ultimate Edition

Microsoft Visual Studio 2015 (C#、VB.NET) Community、Professional、Enterprise

※ ArcObjects SDK 10.4.x ~ 10.5 for Microsoft .NET Framework において幾つかの既知の制限がございます。
※ 詳細については Esri 製品サポート をご参照ください。

Microsoft .NET Framework 4.5 以上

631 MB

 

オペレーティング システムの要件および制限事項

  • 64 ビット プロセッサのサポート
  • Windows 7 制限事項
  • 3D アプリケーション(ArcGIS 3D Analyst の ArcGlobe、ArcScene など)は、リモート デスクトップや Windows Terminal Services クライアント上では最適な状態で動作しません(これらの環境で OpenGL 3D グラフィックス アクセラレータをサポートしないため)。
Copyright© 2002-2018 Esri Japan Corporation. All rights reserved.
トップへ戻る