製品 > ArcGIS Runtime SDK for Android > 動作環境

ArcGIS Runtime SDK for Android

動作環境

ArcGIS Runtime SDK for Android

 

100.12 100.11 100.10 100.9 100.8 100.7 100.6 100.5 100.4 100.3 100.2.1 100.2 100.1 100.0
10.2.9 10.2.8-1 10.2.8

バージョン 100.12 (最新バージョン), 100.11, 100.10

開発環境

開発ツール

  • Android Studio
  • IntelliJ IDEA

ツールキット

  • Android SDK

開発言語

  • Java, Kotlin
クライアント環境

実行環境

  • Android 6.0 (Marshmallow) 以上

OpenGL ES

  • 2D
    • OpenGL ES 2.0 以上 (3.0 を推奨)
  • 3D
    • OpenGL ES 3.0 以上
  • 動作環境の詳細は米国 Esri 社の System requirements ページも併せてご確認ください。

 

バージョン 100.9,100.8

開発環境

開発ツール

  • Android Studio
  • IntelliJ IDEA

ツールキット

  • Android SDK
  • Java Development Kit (JDK) ※1

開発言語

  • Java, Kotlin ※2
クライアント環境

実行環境

  • Android 5.0 (Lollipop) 以上

OpenGL ES

  • 2D
    • OpenGL ES 2.0 以上 (3.0 を推奨)
  • 3D
    • OpenGL ES 3.0 以上

※1.JDK はバージョン 7 以上をご使用ください。
※2.Kotlin のサポートはバージョン 100.2 から対応。
※ Google Play へアプリを公開する際は、32bit 版に加え、64bit 版の提供も必要となります。詳細は 64 ビット アーキテクチャのサポートをご参照ください。

 

 

100.7, 100.6, 100.5, 100.4, 100.3

開発環境

開発ツール

  • Android Studio
  • IntelliJ IDEA

ツールキット

  • Android SDK
  • Java Development Kit(JDK)※1

開発言語

  • Java, Kotlin ※2
クライアント環境

実行環境

  • Android 4.4(Kitkat)以上

OpenGL ES

  • 2D
    • OpenGL ES 2.0 以上(3.0を推奨)
  • 3D
    • OpenGL ES 3.0 以上

※1.Android 4.4(Kitkat)をご使用の場合、JDK はバージョン 6 以上をご使用ください。Android 5.0(Lollipop)以上をご使用の場合、JDK はバージョン 7 以上をご使用ください。
※2.Kotlin のサポートはバージョン100.2 から対応。

 

 

100.2.1, 100.2, 100.1, 100.0

開発環境

開発ツール

  • Android Studio
  • IntelliJ IDEA

ツールキット

  • Android SDK
  • Java Development Kit(JDK)※1

開発言語

  • Java, Kotlin ※2
クライアント環境

実行環境

  • Android 4.1(Jelly Bean)以上

OpenGL ES

  • OpenGL ES 2.0 以上

※1.Android 4.1(Jelly Bean)~ Android 4.4(Kitkat)をご使用の場合、JDK はバージョン 6 以上をご使用ください。Android 5.0(Lollipop)以上をご使用の場合、JDK はバージョン 7 以上をご使用ください。
※2.Kotlin のサポートはバージョン 100.2 から対応。

 

10.2.9, 10.2.8-1, 10.2.8(2019/12/1 サポート終了)

開発環境
JDK
  • Java Development Kit

開発ツール

  • Android Studio

開発言語

  • Java
クライアント環境
Android 4.0.3(Ice Cream Sandwich)以上